Having trouble using Font Awesome with Vue.js? This page is all about getting you unstuck.

Advertisement

Upgrading from Version 4

If you're upgrading from Version 4, there are a number of changes that you need to be aware of before you jump into Version 6. We've tried to make it as painless as possible, but you may need to make some changes in your project to have it work correctly.

Using Vue 3

The vue-fontawesome compenent currently only supports Vue 2. We're still working on the packages for Vue 3. Stay tuned!