You're viewing docs for v5.15.4, an older version of Font Awesome.

Font Awesome icons are popular, and it is common for other themes and plugins to load Font Awesome. So we created a way to help you find and prevent those conflicting versions from affecting your icons: The Conflict Detection Scanner.

If the official Font Awesome plugin seems to be set up correctly, but your icons still aren’t loading, and you're not sure why head over to the Troubleshoot tab. The Troubleshoot area of the plugin has two parts:

  • Detect Conflicts with Other Versions of Font Awesome
  • Versions of Font Awesome Active on Your Site

Detect Conflicts

The Detect Conflicts with Other Versions of Font Awesome section lets you enable the conflict scanner tool, which then looks for versions of Font Awesome loading on your site. Once you click the button to enable the scanner, a blue scanner box will appear in the lower right corner of your browser window, like this:

Conflict detector shows in the bottom right of your browser for 10 minutes

Conflict detector shows in the bottom right of your browser for 10 minutes

It will run in the corner (but only be visible to admins) while you visit any page or area of your site having trouble loading icons correctly. As you browse, it will scan and let you know if it finds other versions of Font Awesome on the pages you visit and save them to the lower part of the Troubleshoot tab. Once you're done, you can view the Versions of Font Awesome Active on Your Site section results.

Review Active Font Awesome Versions

The upper area of the Versions of Font Awesome Active on Your Site section shows any registered themes or plugins using Font Awesome. These have opted to show you what settings they prefer, and you can adjust your plugin settings to align. If you have multiple plugins with different needs, you can decide which is more important to align with.

The lower area lists any other versions of Font Awesome that may be loading on your site — these are the results from the conflict scanner. If the scanner finds a potential conflict, it adds it here, and you can choose to block it from loading that other version of Font Awesome. Since we can't tell who or what is loading those other versions, we provided a little information that may help you figure out the type of resource and the URL that is loading Font Awesome. The results will remain there until you clear it, even if you remove the plugin or theme that generated it. If you think you’ve removed a plugin or theme that was creating a conflict, you can clear that result and see if it pops up again. Or you can clear them all and start fresh anytime. Remember to save after you clear or block an item.

Conflicts in the CDN or Kit Settings

If a plugin or theme has registered preferred settings and you are changing the settings to something different, you’ll see a warning message about which plugin or theme might have issues with the new settings, like this:

A settings conflict will warn you if you select different settings than a plugin is expecting

A settings conflict will warn if you select different settings than a plugin is expecting

You can still save the conflicting settings, but the plugin or theme may not work as expected. You can also visit the Troubleshoot tab to see what settings the plugin(s) or theme(s) prefer — the differences with your settings will be highlighted.